DropsuiteEMEA - Authentication Failures Affecting Tenant Credentials – Incident details

Authentication Failures Affecting Tenant Credentials

Resolved
Degraded performance
Started about 1 month agoLasted about 3 hours
Updates
  • Resolved
    Resolved

    Root Cause
    The issue was triggered by the expiration of the application secret used in the London region, which disrupted authentication services for some organizations.

    Resolution
    We generated a new application secret and applied the update in the London region. Authentication services have been refreshed for all affected organizations, and normal functionality has been fully restored.

    We sincerely apologize for the disruption and are implementing preventive measures to avoid similar occurrences in the future.

  • Identified
    Identified

    We have identified the issue and are currently working towards a resolution.

  • Investigating
    Investigating
    We have identified an issue affecting authentication for organizations, where tenant credentials are failing to authenticate and re-authentication attempts are also unsuccessful. Our engineering team is actively investigating this issue with high priority to determine the root cause and implement a resolution. We will provide updates as more information becomes available.